Auteur Sujet: Incohérences lors d'un import Neptune  (Lu 1559 fois)

mtram

  • Utilisateur
  • *
  • Messages: 13
    • Voir le profil
Incohérences lors d'un import Neptune
« le: mars 25, 2014, 12:23:57 pm »
Bonjour,

J'ai rencontré 2 soucis lors d'un import d'un fichier au format Neptune (j'utilise la version 2.1.0) :

- Je ne retrouve pas mes transporteurs tels que définis par des balises <Company> dans le fichier en entrée. Cela fonctionne lorsque je n'en ai qu'un seul, mais dès l'ajout d'un 2ème dans le même fichier, aucun transporteur n'est alors créé.

- L'absence de la balise <journeyPatternId> comme enfant de <VehicleJourney> fait qu'aucun enregistrement n'est ajouté en base lors de l'import.

Vous serait-il possible de confirmer si des bugs dans Chouette ou non?
Merci d'avance.


Metienne

  • Utilisateur
  • *
  • Messages: 141
    • Voir le profil
Re : Incohérences lors d'un import Neptune
« Réponse #1 le: mars 25, 2014, 06:27:22 pm »
Bonjour,

Lors d'un import Neptune, le premier transporteur est associé automatiquement à la ligne décrite dans le fichier
 les autres transporteurs ne sont importés que s'ils sont explicitement associés à au moins une course (VehicleJourney)

En espérant avoir répondu à votre question
Cordialement,
Michel Etienne

mtram

  • Utilisateur
  • *
  • Messages: 13
    • Voir le profil
Re : Incohérences lors d'un import Neptune
« Réponse #2 le: avril 09, 2014, 03:11:28 pm »
En effet en modifiant le fichier en entrée, je retrouve bien mes transporteurs comme attendu.

Merci.