Auteur Sujet: Exports vides  (Lu 851 fois)

vcournede

  • Utilisateur
  • *
  • Messages: 14
    • Voir le profil
Exports vides
« le: novembre 29, 2016, 03:26:23 pm »
Bonjour,

Après avoir pas passé notre préproduction de chouette-docker sur la branche 3.4 du github.

Nous avons un problème lors d'un export des données: Lorsque nous créons un nouvel export, l'export en lui-même passe en vert mais n'affiche aucun lien de téléchargement du fichier exporté.
De plus quand nous visualisons le contenu de cet export en cliquant sur son nom, il nous affiche ''aucun test'' sur l'onglet Test, et rien du tout sur les autres onglets.

Nous avons le même problème avec les validations sauf qu'elles arrivent automatiquement en échec.

Je joins des captures d'écran qui seront mieux représentatives.

Cordialement,
« Modifié: novembre 29, 2016, 03:29:35 pm par vcournede »

Aurige

  • Administrator
  • Utilisateur
  • *****
  • Messages: 49
    • Voir le profil
Re : Exports vides
« Réponse #1 le: novembre 29, 2016, 04:18:09 pm »
Bonjour
Je vais faire quelques tests sur ma version dans se sens (en fin de journée). Entre temps, pouvez vous confirmer que les fonctions d'import et validation d'import fonctionnent sur votre chouette-docker, et si non, indiquer les erreurs rencontrées. Merci d'avance.

vcournede

  • Utilisateur
  • *
  • Messages: 14
    • Voir le profil
Re : Exports vides
« Réponse #2 le: novembre 29, 2016, 05:20:19 pm »
Bonjour,

Effectivement, je viens de tester l'import ne fonctionne plus.

Cordialement,

Aurige

  • Administrator
  • Utilisateur
  • *****
  • Messages: 49
    • Voir le profil
Re : Exports vides
« Réponse #3 le: novembre 29, 2016, 05:35:23 pm »
Dans ce cas là vous avez probablement un problème de droit sur les répertoires de données.

vérifiez si, à partir des racines des points de montage utilisés pour les images vous disposez bien d'un répertoire .../data/referentials et que lorsque que vous faites un import, que le fichier à importer arrive dans un de ses sous-répertoires (quelque chose comme ...\data\referentials\ch_1\data\1\input ).
Si ce n'est pas le cas, vérifier les droits d'écriture dans cette arborescence (mettre les droits d'utilisateur "Chouette" sur le répertoire) ?

vcournede

  • Utilisateur
  • *
  • Messages: 14
    • Voir le profil
Re : Exports vides
« Réponse #4 le: novembre 29, 2016, 05:56:20 pm »
Le fichier à importer arrive bien dans l'un de ces répertoires, les droits ont été modifiés et le fichier se retrouve bien dans le dossier :

/data/referentials/ch_17/data/109/

Ceci a été testé avec un nouvel espace de données et un nouvel import.

Par contre du côté de l'interface, nous avons toujours les imports, exports et validations en erreur.

Cordialement,

Aurige

  • Administrator
  • Utilisateur
  • *****
  • Messages: 49
    • Voir le profil
Re : Exports vides
« Réponse #5 le: novembre 30, 2016, 09:52:56 am »
J'ai fait des tests de mon côté avec ma version Docker (aussi en 3.4) et les exports se passent sans problème.
Je vais demander l'avis de l'équipe de développement
Quel est votre environnement (Linux, Mac, Windows...) ?

vcournede

  • Utilisateur
  • *
  • Messages: 14
    • Voir le profil
Re : Exports vides
« Réponse #6 le: novembre 30, 2016, 10:12:35 am »
Bonjour,

C'est du Linux, plus précisément Centos 7.

Cordialement,

Bruno Perles

  • Utilisateur
  • *
  • Messages: 11
    • Voir le profil
Re : Exports vides
« Réponse #7 le: novembre 30, 2016, 10:27:02 am »
Bonjour,

Que vous retourne la commande : docker ps
Comme ça, à vue de nez, je dirai qu'il manque le conteneur Redis !
« Modifié: novembre 30, 2016, 10:54:00 am par Bruno Perles »

vcournede

  • Utilisateur
  • *
  • Messages: 14
    • Voir le profil
Re : Exports vides
« Réponse #8 le: novembre 30, 2016, 03:19:37 pm »
Bonjour,

Le conteneur redis était bien lancé, pour être sûr j'ai relancé le tout.

Voici donc le résultat de la commande docker ps:


CONTAINER ID        IMAGE                          COMMAND                  CREATED             STATUS              PORTS                                            NAMES
27ae8b91a9a0        afimb/chouette2:v3.4           "/docker-entrypoint.s"   11 minutes ago      Up 11 minutes       0.0.0.0:80->3000/tcp                             chouette_chouette2_1
caeeb061c4ae        afimb/chouette-iev:v3.4        "/docker-entrypoint.s"   11 minutes ago      Up 11 minutes       0.0.0.0:8081->8080/tcp, 0.0.0.0:9991->9990/tcp   chouette_chouette-iev_1
59d49c5ac03c        redis                          "docker-entrypoint.sh"   11 minutes ago      Up 11 minutes       0.0.0.0:6379->6379/tcp                           chouette_redis_1
6d081c71f5d2        tophfr/mailcatcher:latest      "mailcatcher --foregr"   11 minutes ago      Up 11 minutes       0.0.0.0:1025->25/tcp, 0.0.0.0:1080->80/tcp       chouette_mailcatcher_1
0b2afe4b5ddd        afimb/chouette-postgres:v3.4   "/docker-entrypoint.s"   11 minutes ago      Up 11 minutes       0.0.0.0:5433->5432/tcp                           chouette_chouette-postgres_1


Même avec le redémarrage de chaque conteneur, le problème persiste.

Cordialement,

Aurige

  • Administrator
  • Utilisateur
  • *****
  • Messages: 49
    • Voir le profil
Re : Exports vides
« Réponse #9 le: novembre 30, 2016, 03:51:41 pm »
Je viens de redéployer la V3.4 Docker pour être sûr d'avoir la même que vous, et tout va bien de mon côté.

Vous indiquez dans votre premier message une erreur lors de la validation de la base. Selon l'erreur que vous avez, cela peut bloquer l'export. Est-ce que vous avez accès au détail de cette erreur de validation ?

vcournede

  • Utilisateur
  • *
  • Messages: 14
    • Voir le profil
Re : Exports vides
« Réponse #10 le: novembre 30, 2016, 04:12:50 pm »
Depuis l'interface, quand je clique sur la validation, dans l'onglet des tests, cela m'affiche ''aucune test'', sur l'onglet des fichiers ''aucun fichier'' et rien dans l'onglet ''Données de transport''.
Il y a t-il un autre moyen d'avoir plus de détail?

Cordialement,

Bruno Perles

  • Utilisateur
  • *
  • Messages: 11
    • Voir le profil
Re : Exports vides
« Réponse #11 le: novembre 30, 2016, 04:17:10 pm »
Il y a un soucis de communication entre Chouette2 et IEV.
Très probablement une problématique de droits quelque part.
Si besoin je peux via TeamViewer ou SSH me connecter et regarder, ce sera peut-être plus simple.

vcournede

  • Utilisateur
  • *
  • Messages: 14
    • Voir le profil
Re : Exports vides
« Réponse #12 le: décembre 02, 2016, 08:48:13 am »
Bonjour,

Oui aucun problème, je vous recontacte par MP.

Cordialement,

vcournede

  • Utilisateur
  • *
  • Messages: 14
    • Voir le profil
Re : Exports vides
« Réponse #13 le: décembre 14, 2016, 11:57:16 am »
Bonjour,

Après intervention avec vous, les exports fonctionnent normalement sauf... les GTFS.

Avec lesquels nous avons les mêmes erreurs que précédemment sachant qu'aucun fichier GTFS n'est créé à l'export dans /data/referentials/ch_ID/data/NB/output.

Auriez-vous une idée d'où pourrait venir le problème? Sachant que les exports Neptune et NeTex fonctionnent parfaitement.

Cordialement,

Metienne

  • Utilisateur
  • *
  • Messages: 136
    • Voir le profil
Re : Exports vides
« Réponse #14 le: décembre 22, 2016, 03:31:27 pm »
Je vous recontacte par mail