Auteur Sujet: Utilisation de Chouette-Command  (Lu 8503 fois)

pmaldi

  • Utilisateur
  • *
  • Messages: 16
    • Voir le profil
Re : Utilisation de Chouette-Command
« Réponse #15 le: janvier 13, 2015, 02:37:04 pm »
Citer
# Load the rails application
require File.expand_path('../application', __FILE__)


# Initialize the rails application
ChouetteIhm::Application.initialize!

# Fix version
APP_VERSION = '2.5.1'

Je confirme bien la 2.5.1. Le bundle install a été fait aussi (oublié de marquer dans le poste) :

Citer
bundle install
*Using rake 10.3.2
Using RedCloth 4.2.9
Using SyslogLogger 1.4.1
Using i18n 0.6.11
Using multi_json 1.10.1
Using activesupport 3.2.18
Using builder 3.0.4
Using activemodel 3.2.18
Using erubis 2.7.0
Using journey 1.0.4
Using rack 1.4.5
Using rack-cache 1.2
Using rack-test 0.6.2
Using hike 1.2.3
Using tilt 1.4.1
Using sprockets 2.2.3
Using actionpack 3.2.18
Using mime-types 1.25.1
Using polyglot 0.3.5
Using treetop 1.4.15
Using mail 2.5.4
Using actionmailer 3.2.18
Using active_enum 0.9.12
Using arel 3.0.3
Using tzinfo 0.3.42
Using activerecord 3.2.18
Using activeresource 3.2.18
Using acts-as-taggable-on 3.4.2
Using acts_as_list 0.1.6
Using acts_as_tree 2.1.0
Using acts_as_tree-1.8 1.1.0
Using addressable 2.3.5
Using bcrypt-ruby 3.0.1
Using breadcrumbs_on_rails 2.3.0
Using open4 1.3.0
Using calendar_helper 0.2.5
Using highline 1.6.15
Using net-ssh 2.6.2
Using net-scp 1.0.4
Using net-sftp 2.0.5
Using net-ssh-gateway 1.1.0
Using capistrano 2.13.5
Using capistrano-ext 1.2.1
Using nokogiri 1.5.10
Using ffi 1.9.6
Using childprocess 0.5.3
Using rubyzip 1.1.6
Using websocket 1.2.1
Using selenium-webdriver 2.43.0
Using xpath 0.1.4
Using capybara 1.1.2
Using choice 0.1.6
Using cocoon 1.1.2
Using coffee-script-source 1.3.3
Using execjs 1.4.0
Using coffee-script 2.2.0
Using rack-ssl 1.3.4
Using json 1.8.1
Using rdoc 3.12.2
Using thor 0.19.1
Using railties 3.2.18
Using coffee-rails 3.2.2
Using daemons 1.1.9
Using fastercsv 1.5.5
Using dbf 2.0.7
Using deep_cloneable 2.0.0
Using delayed_job 3.0.3
Using delayed_job_active_record 0.3.2
Using orm_adapter 0.4.0
Using warden 1.2.1
Using devise 2.1.3
Using devise-encryptable 0.1.2
Using devise-i18n 0.10.3
Using devise_invitable 1.1.0
Using diff-lcs 1.2.1
Using dr-apartment 0.14.1
Using dr-ffi-proj4 0.0.3
Using factory_girl 2.6.4
Using factory_girl_rails 1.7.0
Using ffi-geos 1.0.0
Using sass 3.4.5
Using font-awesome-sass 4.2.0
Using foreigner 1.6.0
Using formtastic 2.3.1
Using geokit 1.6.7
Using georuby 2.3.0
Using rgeo 0.3.20
Using georuby-ext 0.0.5
Using google-analytics-rails 0.0.4
Using gravatar_image_tag 1.2.0
Using rb-fchange 0.0.5
Using rb-fsevent 0.9.1
Using rb-inotify 0.8.8
Using listen 0.4.7
Using guard 1.3.2
Using guard-rspec 1.2.1
Using has_scope 0.6.0.rc
Using responders 1.0.0
Using inherited_resources 1.4.1
Using jquery-rails 2.2.1
Using jquery-ui-rails 4.0.3
Using jquery-ui-sass-rails 4.0.3.0
Using bundler 1.7.9
Using rails 3.2.18
Using language_engine 0.0.5
Using launchy 2.3.0
Using libv8 3.3.10.4
Using map_layers 0.0.4
Using modernizr-rails 2.0.6
Using morrisjs-rails 0.4.3
Using ninoxe 1.1.0
Using pg 0.11.0
Using polyamorous 1.1.0
Using rabl 0.7.8
Using rails-assets-jquery 2.1.1
Using rails-assets-bootstrap 3.1.1
Using rails-assets-bootstrap-sass-official 3.3.0
Using rails-assets-moment 2.8.3
Using rails-assets-eonasdan-bootstrap-datetimepicker 3.1.3
Using rails-assets-respond 1.4.2
Using rails-assets-tagmanager 3.0.1
Using rails-assets-typeahead.js 0.10.5
Using rails-assets-typeahead.js-bootstrap3.less 0.2.3
Using ruby-graphviz 1.0.9
Using rails-erd 1.1.0
Using ransack 1.4.1
Using raphael-rails 2.1.2
Using rspec-core 2.13.0
Using rspec-expectations 2.13.0
Using rspec-mocks 2.13.0
Using rspec 2.13.0
Using remarkable 4.0.0.alpha4
Using remarkable_activemodel 4.0.0.alpha4
Using remarkable_activerecord 4.0.0.alpha4
Using ruby-ole 1.2.11.7
Using spreadsheet 0.9.7
Using roo 1.13.2
Using rspec-rails 2.13.0
Using sass-rails 3.2.6
Using shoulda-matchers 1.2.0
Using simple_form 2.1.1
Using sqlite3 1.3.6
Using squeel 1.2.1
Using therubyracer 0.10.2
Using uglifier 1.2.7
Using will_paginate 3.0.5
Using will_paginate-bootstrap 1.0.0
Your bundle is complete!
Use `bundle show [gemname]` to see where a bundled gem is installed.

Mais c'est toujours la version 2.5.0 qui s'affiche.


Bug d'affichage ? sur un autre poste pareil 2.5.0 afficher et après les commandes de migration pas d'ajout de colonne dans la table.
Je vois pas trop ou ce trouve le problème.

Ps : Webrick a été relancé depuis et le serveur redémarré.

pmaldi

  • Utilisateur
  • *
  • Messages: 16
    • Voir le profil
Re : Utilisation de Chouette-Command
« Réponse #16 le: janvier 14, 2015, 09:55:38 am »
Cette discussion a été continué en privé.

Le problème semble être venu de la cohabitation de 2 versions chouette sur le même serveur lors d'une mise a jour de la version 2.5.0 > 2.5.1.
Cependant mon problème semble être un cas isolé.

Configuration :

2 Dossier "chouette2" et "chouette2.5.0.old"
"chouette2" correspond a la version 2.5.1.


Une méthode de résolution :

- Compresser le dossier "chouette2.5.0.old"
- Supprimer le dossier "chouette2.5.0.old"
- Fermer le terminal (Très important)
- Ouvrez le terminal et aller dans "chouette2"
- bundle install --path vendor/bundle (ça va prendre quelques minutes)
- RAILS_ENV=production bundle exec rake db:create apartment:migrate
- RAILS_ENV=production bundle exec rake assets:clean assets:precompile
- RAILS_ENV=production bundle exec rails server

Voici la procédure pour moi qui a fonctionné.

Je remercie Metienne pour son attention et son professionnalisme sur ce problème.
« Modifié: janvier 14, 2015, 11:26:23 am par pmaldi »